PredictiveHire is always concerned with security and we recommend customers keep their browsers up to date to avoid security vulnerabilities.


Our current minimum browsers are shown below:

We recommend you upgrade from any browser prior to these versions. They do not allow us to bring the latest browser features to you and they represent security vulnerabilities to your organisation.

Vulnerabilities are continuously identified in browsers, applications and operating systems. They are documented in the common vulnerability and exposures (CVE) list at https://cve.mitre.org/index.html

As an example, consider firefox. Firefox documents which of these CVE’s are fixed in each version of their browser: https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox/ When we go into the link for version 69 we can see the list of vulnerbabilities that version fixed. However, the vulnerabilities in all the versions after that may be present in version 69, so we recommend you upgrade and keep up to date so you avoid those vulnerabilities in your system.

Did this answer your question?